Home > Windows 7 > Setup was unable to create a new system partition or locate an existing system partition. See the Setup log files for more information.

Setup was unable to create a new system partition or locate an existing system partition. See the Setup log files for more information.


I was installing Windows 7 (build 7100) on my workstation to check it out today. At the drive selection screen during install, I tried to select the 2nd primary partition on my hard drive, but received an error:

Setup was unable to create a new system partition or locate an existing system partition. See the Setup log files for more information.

The solution was easy; just disconnect all other hard disks in the system and restart setup. I sure hope MS fixes that before RTM.

Advertisements
Categories: Windows 7 Tags:
  1. Bill
    August 2, 2009 at 10:54 am

    I spent a 3 hours and killed 4 partitions on 2 drives trying to figure this out – should have Googled first ;-(

  2. yo
    September 18, 2009 at 8:39 am

    i just spend a whole day.hope it works now

  3. Anand
    September 25, 2009 at 10:29 am

    Hi…………
    Thank you, thank you, thank you very much, i tried for nearly four hours…….. to find out the solution, i did everything, even i updated bios also :D, but no use, i update storage device drive as well, no use,
    But your solution works just fine, now installation is going on without any problem.

    Thank you Very Much once again.

    IT JUST WORKS PERFECT.

  4. November 1, 2009 at 12:08 pm

    Thank you so much for posting this. That exact issue occurred to me as well, AFTER I formatted the primary HD and so would’ve been screwed. I had an extra internal HD as backup and once I disconnected it the install went through cleanly.

  5. November 3, 2009 at 7:40 am

    Ok, but my problem is worst… I have Ubuntu in the first Partition and same Hard Disk, as known I don’t want kill this Partition, so what I have to do to install Win7???

  6. Sai
    November 27, 2009 at 4:58 pm

    I’ve tried numerous times to install vista but i keep getting that same error message, aswell as with windows 7. I had only one hard drive connected, no removable drives and i still get the error. What does any1 recommend i do?

    • rahul
      August 10, 2011 at 4:12 am

      you just remove your pendrive or usb related part……and restart installing..

  7. Xander Cage
    December 6, 2009 at 4:26 pm

    Well,after a while i’ve got it. I used everything that i could on google,nothing was helpful. I didn’t disconnect any drive , i just used Hiren’s boot and with Paragon partition manager i’ve formated the partition NTFS and set it primary. After that it worked just fine the install and everything was back to normal. I’ve tryed disconnection the drives,i’ve tryed bootsect from the recovery console,i’ve tryed alot of things without any help.

    • July 21, 2010 at 11:58 am

      yeah dude that was the perfect solution to my issue. hiren’s worked perfectly and such a great tool to have as a tech. and paragon was the best solution. i spent two days trying to fix this f..n problem.

  8. ashis
    October 13, 2010 at 11:36 am

    when i was trying to install the windows 7.
    whenever i come to the disk partition part at the left side bottom it shows ‘Windows cannot be installed to this disk.(show details). when i click it . It shows “windows is unable to install to the selected location . Error :0x80300001.
    Windows cannot be installed to this disk.This computer’s hardware may not support booting to this disk.Ensure that
    the disk’s controller is enabled in the computer’s BIOS menu.” when i click it to ok and then next.
    then it pop-ups “setup was unable to create a new system partitionor locate an existing system partition.see the setup log files for more information.” then i click next it wont continue to the next stage……. please help me my pc is hp compaq 6710b…..and having a hdd of 500gb… please help me…..

  9. rahul
    August 10, 2011 at 4:10 am

    tahnks dear its working……………….

  10. Guru
    December 24, 2012 at 12:34 pm

    Sir,this error should be displayed for each time after set the partition. But doesn’t solve pls help me without using any drivers

  1. October 21, 2009 at 7:09 pm
  2. February 16, 2010 at 1:36 pm

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

%d bloggers like this: