Home > SharePoint > Slow SharePoint (MOSS 2007) Windows Explorer View using Windows 7 and Internet Explorer 8 (IE8)

Slow SharePoint (MOSS 2007) Windows Explorer View using Windows 7 and Internet Explorer 8 (IE8)


Ever since installing Windows 7, it was excruciatingly painful waiting for the “Open With Windows Explorer” view to work with SharePoint. Click-throughs, renames, file copies and any other operation in this view took 50x’s longer than it did in Vista.

I found a fix that was relatively simple, though I don’t really have an explaination.

  1. In IE8, go to Tools > Internet Options
  2. Click the Connections tab, then the LAN Settings button
  3. If Automatically detect settings is checked, uncheck it
  4. Reboot

A word of warning – I had multiple windows and applications open while I tried this operation and it slowly locked up the system to the point I couldn’t close windows, reboot or even bring up task manager. This happened on another machine I was using as well. Consider performing this operation and rebooting immediately.

Advertisements
Categories: SharePoint Tags:
  1. Roman
    October 23, 2009 at 4:42 am

    THANKS! THANKS! THANKS! THANKS! THANKS!
    You saved my mental health!

  2. julio
    November 21, 2009 at 1:29 am

    don’t change a thing, win explorer is still slow.

  3. Maria
    December 3, 2009 at 10:57 am

    Excellent posting. Thank you very much!

  4. Jack
    January 3, 2010 at 10:36 pm

    I’m using IE7 & the speed is painful (only happens to few users_. Firefox loads SharePoint very fast. what a shame Microsoft

  5. Mark
    February 5, 2010 at 7:28 am

    Thanks mate!
    Now it runs… 😉

  6. TomC
    July 22, 2010 at 6:31 am

    A huge thank you, my computer was about to go swimming but now great.

  7. Mike
    August 11, 2010 at 8:37 pm

    thanks my man that instantly fixed it

  8. Vincent
    November 8, 2010 at 11:46 am

    Thanks ! that fixed my problem !!

  9. Pierre
    April 5, 2011 at 8:06 am

    Thank you! Merci! Danke! Gracias!
    Instant and tremendous improvments!

  10. todd
    April 5, 2011 at 1:21 pm

    installed win7-x64 and IE9 and had issues with SP Explorer view until I found this post. Instantly resolved my slow issues, thanks!

  11. Maskedweb
    May 26, 2011 at 3:17 am

    Great Post thank you – worked like a charm

  12. victim
    July 1, 2011 at 5:41 am

    GREAT. 1000 THXs

  13. September 13, 2011 at 11:36 am

    Easy and effective! Thanks! Transfer speeds went from a file every few seconds to 100s per.

  14. Brian P
    November 22, 2011 at 12:02 pm

    Worked beautifully on Windows Server 2008 R2. I was trying to move lots of files from SharePoint to a file share and it was transferring at 100KB/s, after unchecking this box it changed to 15MB/s. Many thanks!

  15. Brian P
    November 22, 2011 at 12:02 pm

    Also, a reboot was not required, it took effect immediately.

  16. Larry W. Virden
    August 7, 2012 at 7:09 am

    Thank you for the tip. Unfortunately, that doesn’t help in our case at all. We see literally no difference unchecking the box – we still see things take minutes that took seconds under XP and IE7.

  17. netadmin
    September 10, 2012 at 9:12 am

    Problem fixed. Thank You

  1. No trackbacks yet.

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

%d bloggers like this: